Blinds Control, servo not responding


Having started from scratch with my smart blinds setup, a fully assembled kit received only a few days back, I got all the way through the instructions to the point of testing the motor using MQTT.fx. I was able to send instruction and see the response, including the motor actually moving. I then tried to connect The MQTT Mosquito server to OpenHAB 2 without any success. However, in trying to get this connection working something has gone wrong with the MQTT part, or possibly the motor (but I can’t see how to locate the problem). I need to get the motor responding again before attempting to connect to OpenHAB 2.

So, now from MQTT.fx I can see in the correct “Topic” (which I have cut/pasted from the web interface for the controller - this web page loads fine proving the controller is online at the expected IP). When the controller is powered off, and I publish anything to the Topic, I see it send but get no response (as expected). As soon as it is powered on, the Topic/Status appears, and it brings back the value 52. This suggests to me that the controller is successfully talking to my Mosquito broker. However, it doesn’t matter what command (number from 0-100) I send to the device, the status comes back each time as 52, and the motor does not move.

I’ve reset the config on the device (ie, wiped it via the jumpers, given it a different name, topic, even changed the speed), can still connect to it via it’s web page, and also still get the same responses via MQTT.fx. Also gone through the instructions to re-flash the controller with the v2 firmware, but this made no difference. I’ve also tried a new power supply for the motor/controller. I’m now thinking that the motor itself is the problem but wondering if that’s the kind of behaviour you’d expect to see if that was the case? Is there anything else I can do to test? I’ve tried everything I can find on this forum…

Thanks for any ideas, this is really frustrating!!

MQTT.FX works, I see the published topic, but the state comes back the same

Did you compile the code after making the adjustments?
If you did, have you copied the code as Matt used in the tutorial and modify it for your application?
I would go through the code as put in and make sure all syntax that you put into the mosquito application.
Make sure that everything matches and what you put into openHAB that that again matches what you have in your code.


Thanks for the response. I’m not sure that I’ve done anything that would need re-compiling, as I never compiled anything in the first place? Were you thinking of anything in particular?

I’m pretty sure I’ve followed the instructions from scratch but I’m tempted to wipe the pi and start over if there are no better ideas. I would like to find a way to test that the servo actually works though as thinking about it, it did sound a bit unhealthy when I first got it going. Is it a case of finding a 3.3v power source and just connecting it? I’m not sure what the 3 connections are…



You can test your servo by wiring it to an arduino board. Connect, the serial pin, power and ground. Then you can send code to make it turn in either direction. See this video


I’m having issue resetting my blinds because system changed. On one of the videos it says reboot device and quickly change the jumper pin, wait 10 seconds turn off device and replace jumper to run and boot device back up. Is this what you did to get the blinds back to factory default? Or are the steps to resetting the blinds board something else?


Yes I was able to reset by moving the jumper, once rebooted you can reconnect to it’s own SSID and reconfigure the settings.

I fixed my issue. I had configured my router with a name for the device, but stupidly named the device itself (on its own config) something slightly different. Once the names were amended it came back to life :slight_smile: