Cannot control blinds only from basicUI



Could someone please help, I can control servo motor from mqtt.fx app publishing 40 or 50 or any number and the servo motor works returning state but cannot control using Basic UI. Not sure what’s missing.

Below is content of my


Dimmer SMBlindsControl1 “SM Blinds [%s]” [ “Lighting” ] {mqtt=">[broker:SM-SmartHouse/utilities/SM-BlindsControl1:command:*:default],<[broker:SM-SmartHouse/utilities/SM-BlindsControl1/state:state:default]", autoupdate=“false”}


Frame label=“bedroom”
Switch item=SMBlindsControl1 mappings=[0=“Open”, 56=“Half”, 100=“Close”]
Slider item=SMBlindsControl1

I am getting the state back when I publish:

but When I do the same from basicUI, I cannot control or the servo doesn’t move.


Make Sure You Have Installed MQTT Action vi

a Basic UI an Add-ons


@Mountain - Thanks for your response. I got it solved. it’s working now but partially - meaning I couldn’t get the servo motor to fully close the blinds. my blinds are different. it needs more turns to fully close to 100.

How I got it solved:

  • verified the conf file - it was correct.

  • I went to the paper UI, Add Ons - bindings and then installed the MQTT bindings

  • I didn’t know the purpose of Actions, One of the posts, It was recommended to make sure bindings are installed and actions are removed. Thus removed it.

-Then tried, it worked !!!

Hi @mattkaczynski - Thanks for all your video inputs. I couldn’t use the 3d printed parts. since I couldn’t fit it in my blinds - used some card boards and customized the fit. Could you please share the code of servo motor to update few more turns to servo motor and try and see if it’s closing.