[FIXED] Blind Control not working in OpenHab


Hi All,

So iv just tried to setup the V2 blind control. I’m able to control the servo using MQTT FX but its not working from the OpenHab BasicUI.

Can you see anything wrong?

ESP Details:

Hostname: Blinds1
MQTT Server:
MQTT Port: 1883
MQTT Authentication: FALSE
MQTT Command Topic: Curato/utilities/Blinds1
MQTT Status Topic: Curato/utilities/Blinds1/state
Move Slow: TRUE
To update firmware go to: http://Blinds1.local/firmware
To reset device settings restart the device and quickly move the jumper from RUN to PGM, wait 10 seconds and put the jumper back to RUN.


Dimmer Blinds1 “Blinds [%s]” [ “Lighting” ] {mqtt=">[broker:Curato/utilities/Blinds1:command:*:default],<[broker:Curato/utilities/Blinds1/state:state:default]", autoupdate=“false”}


Switch item=Blinds1 mappings=[0=“Open”, 56=“Half”, 100=“Close”]
Slider item=Blinds1



Also, Regarding the mqtt broker in openhab2. Am i correct in thinking that the mqtt.cfg file no longer exists in 2.4 and you configure the IP and port in: Configuration > Things > Edit > MQTT Broker



I have had similar problem with MQTT not working. in OPENHAB 2.4 You need to enable legacy v1 bindings in PaperUI in Configuration -> System. Then the old binding should be available (to install). MQTT Action.



Thanks @Mountain, Il give this a try today.


This fixed my problem. I’m all up and running now. (y)

Thanks @Mountain


Good that this fix worked…Took me awhile to track down


This method is a temporary fix, we will have to migrate to 2.4 once the support has stopped for legacy 1.1.
I am in the process of migrating my site items on a secondary server.
items will now need channels created etc

I am following this link for migrating