Having Problems with Basic Firmware Install and Configuration



I am newbie to adrino and the home automation system. I do have some basic skills so I am not a total loss.

Anyway, I have the Sprinkler Control ESP8266 kit and I already performed all the soldering according to the directions and video. I am using Windows 10 and downloaded the NodeMCU-Py-Flasher-3.0-x64.exe and installed, I downloaded the MK-SprinklerSystemV2.ino.nodemcu.bin, and downloaded both MK-SprinklerSytemV1.ino and MK-SprinklerSystemv2.ino

I have reviewed the other Sensor video on how to connect the Adrino UNO and make the serial connections with the USB.

When I launch the NodeMCU app, it see’s the USB COM port, and I select the parameters for firmware: MK-SprinklerSystemV2.ino.nodemcu.bin, Baud Rate: 11520, Flash mode: Dual I/O, Erase Flash = Yes

When I flash, in the windows below, I see Connecting…____ ( and then it stops after a while )

I don’t know if it is successful or not. I configured the jumpers correctly on both the Adrino Uno and Spprinkler Board according the docs. I see power lights on both the cards.

Side information: I didn’t know that I needed to install the Adrino Sketch application ( loaded 1.8.8) but have since installed and rebooted several times. I didn’t see this in any of the videos or docs but realized when Matt was uploading the INO files, he was using.

Anyway, I realize that I probably skipped some steps but was hoping someone else could help me program this device.



Did you change the jumper from run to learn when you attempted to flash the sprinkler board?
If this is not done your flash will not take.
Good luck!


My jumpers say PGM / RUN. I tried both and no change.


Hi, I was able to get a little further by going back and watching How-to configure the Arduino IDE. However, now when I compile, the INO file, I get the following error message:

Arduino: 1.8.8 (Windows 10), Board: “Generic ESP8266 Module, 80 MHz, Flash, ck, 40 MHz, 40MHz, DIO, 512K (64K SPIFFS), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200”

Build options changed, rebuilding all
Sketch uses 299144 bytes (68%) of program storage space. Maximum is 434160 bytes.
Global variables use 30348 bytes (37%) of dynamic memory, leaving 51572 bytes for local variables. Maximum is 81920 bytes.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Anyone seen this.