MK-Blindcontrol Firmware 7.5 Beta Release fix


Version 7.5 Beta is now available.
Fixed servo now moving full 180 degree range.
Fixed teleementry update problems.
On reboot servo does not flinch anymore. ie not energised on reboot.

Still need to re code remote button feature as this was not working after recompile with new core platform 5.4.
this is a minor inconvienance . stillvworking on fix.

I just wanted to get fix up so we can all close the blinds again correctly. lol

Can you download and install on one blind or test blind before doing the rest.
and let be know the out come.

I did a extensive re write of the code over the last few days.
all seems to be better at this stage.
the provision for 2 seperate sevos on2 different pins still is working ok


Love your work.

Will run a test tomorrow on mine and let you know if I run into any issues with the dual blind setup.


Hi Mountain,

Thanks again!
I have just installed on one to test and can certainly confirm the full range of motion is back which is great.

I have noticed however that when changing from open to closed/closed to open the blinds initially move quite quickly then they proceed at the slow rate (I have slow selected in the settings) its almost like there needs to be some form of slow start or start delay added.

I also found that the Device id or device friendly name isn’t appearing as the client name in my connected device section of my unified controller, they appear as ESP-###### (# = last 6 characters of the mac address) this was the same in 7.10 however.

I will continue to monitor over the coming days and let you know if I notice anything else.

Thanks again for your hard work


Blinds moving quickly then slow again if speed set to slow.


cause . On attach() of servo the default start position is 90 degrees. So the servo moves to that position before running the command to move slowly to your desired position.
Fix write to servo() the last known saved position before attach().
the position is now saved in file.
This was not needed in previous builds.

Device id or Network name isn’t appearing as the client name DHCP showing as ESP-######.

This option broke last year sometime due to upgrades in esp8266wifi and WiFimanager cross communications.
A lot of other developers had problems with their code aswell.
Introduced the command WiFi.begin() was all that was needed.
This was not needed in original V2 codes or V7. Builds

Blinds not moving to full positions. 0 degrees to 180 degrees.
There was a change in the default setting of servo.h that was released in the library.
If you Attach() to servo it uses default min and max pulse width of 1000 and 2000.
they were 544 and 2400 originally by default
changing myservo.Attach(Pin,544, 2400) gave back 0-180 movement.

The following still needs attention
Set limits
Telementry upating minor errors when you adjust the limits…if not default settings.
(Trying to get the maths correct…LOL). in progress won’t affect standard setups

Remote button stopped working aswell…this is still being worked on as to a fix.

I should have a 7.51 Beta release for testing in the next few days


I am unable to download the latest 7.5 bin file. Did you take it down? I get 404 error when I try


Telementry updating ;

Set Limits. Menu option GUI
Needs fine tuning as it an behave jittery when moving blind with mouse and arror keys.v Need to just pulse arrow key in steps.
Have enabled also in Setup option to set limits by entering the values ie 170 etc.

Remote Button
This is still in progress of being fixed as it broke in the re build phase.
this will be resolved in the next release.

As these last 2 problems are minor and won’t affect standard installs and operation
the firmware is available on the repo server.
Please test one out and get back to me.


So far so good with one of my blinds. I’ll try the other one this weekend.


Remote Button (open ,close. open half and option to reset)

new version now available on repo servo V7.52 Beta

Download manually and install and test one blind before proceeding.

You will need to change the OTA server in setup if you want to download via the auto option in firmware upgrade in the GUI.


Again Sorry it took awhile to fix the erros . A big rework of the code was required.

Convert from JSON 5 to Version 6…in progress (1/2 way there)
Clean up code for limit set and make it more stable in servo moves via GUI . In progress
Finish the hardware side of Solar and battery operation. Firmware done and already coded.

Please let us know how the new version goes.

Note the servo will still jolt or move quickly between 90 degrees and set limit on reboot or power up.As before.
Have not detected any jolts on software only restarts or re-connections.


Worked great on my test bench unit, put into production so far so good! Well done!


Thanks that great news all is working.
Have released 7.53 on Repo Server and is available to download via GUI for AUTO upgrade
This is a minor upgrade as I found some spelling errors in GUI and I changed some Names in the descriptions
Added DHCP/Network Name. e.g. Mkblindcontrol1 would show up in network connections or client on the router…


I updated my second blinds and things didn’t go well. The default limits and servo mounting side were off. I tried changing values in setup and then increasing levels of resets but nothing worked. I think the blinds are now in a boot loop. They will reply to pings for a few seconds and then stop replying for a few seconds and then repeat. The web interface never comes up. Do you have any suggestions on what to try next? I assume it’s possible to reflash over USB but I’d really don’t want to have to take the blinds down to do that.


Have you unplugged the power and re powered up? I had one that required this for some reason.

I had one that needed to be reflashed, but after that it responded to all upgrades right up to latest release

Not sure what is causing this.


I’m pretty sure I tried that yesterday but just did again to be sure. No change. It still looks to be in a boot loop.

I’ve never flashed one of Matt’s devices directly. Can it be done setting a jumper and connecting USB to the computer or do I have to dig out my FTDI device and connect the pins to it? Also, can Tasmotizer or ESPTool be used or do I have to download and install some ESP dev kit?


Will need the FTDI Adaptor. And I use the Tasmotizer loader found it better than ESPtool.
You will need to put jumper to the pgm position before powering up.


Thanks. I prefer Tasmotizer myself, too.


Also are you using the latest 7.53 ?


Yes, this is all with 7.53.


Hmmm Strange why it did not take.
I re loaded the firmware via the GUI again and still works ok…

From what I have read on google other people are getting reboot loops after upgrading firmware.

see this link

I then installed on a new reflashed esp8266 and yes got same problem. boots up can go into GUI then drops out. goes into AP mode loop etc.
According to the net can be caused by corrupt modules or file system and changes is SDK versions. Hmmmm

Their advised fix is to erase flash then reload firmware. Try the below steps before this action.

I have recomiled agian the same version but did a clean on the compiler. libs are deleted and recomplied
Managed to get into old GUI after a restart. and went staight to Firmware update and did a manual load of the re compiled version.
So far all ok. no reboot cylic loops. GUI stay sound
Did a autyo upgrade from OTA Server as well seems ok.

So re down load v7.53 again from OTA and use this one.

Steps to try to fix.

Re boot device.
Wait for awhile then see if device is listed as a AP wifi. If so connect and do a device reset.
Re connect again and select you SSID and enter password, MQTT detail etc.
We just need it to connect to the network and MQTT.

Try accessing the GUI and select firmware upgrade. If you can access this then do a manual upload of the latest v7.53 (the recomiled one).

If upgrade OK and you can get back into GUI then continue device setup .

If this fails then need to do USB flash method with FTDI Adaptor. 3v or 5v ?

(Note on .FTDI Adaptor, and voltage output.)
I had the problem of header failure when writing to eprom etc and time out errors, the FTDI was only giving 3.7 volts instead of 5V. not enough juice .
I connected the 5v from power supply to pcb as normal to overcome the shortfall ONLY on the 5V input of the PCB…Not to the esp8266 directly…