Mk blinds in ine home assistant


#1

since my raspberry crashed i can not restore my original version of home assistant. So i was forced to install version 105, but unfortunately original yaml file from MK Smarthouse does not work in new home assistant. does anybody knows how to configure this blinds in esphome files or knows how to configure yaml file in configurator. thanks in advance


#2

Hi, I feel for you…happend to me once, then I started dumping my config to my local NB. I just migrated off a pi3, I’m on a Qotom-Q555G6 as of last week for that reason. Overkill for HA but I’ve had several Samsung high end SD cards fail over time and I’m going to add a bunch of things as well.

I have 4 blinds, here’s my config for the V4 firmware Mountain wrote.

cover:

  • platform: mqtt
    name: “Right Window Blinds”
    command_topic: “blinds/utilities/blinds1”
    state_topic: “blinds/utilities/blinds1/state”
    retain: true
    payload_open: “100”
    payload_close: “0”
    payload_stop: “60”
    state_open: “100”
    state_closed: “0”
    tilt_command_topic: “blinds/utilities/blinds1”
    tilt_status_topic: “blinds/utilities/blinds1/state”
    tilt_min: 0
    tilt_max: 100
    tilt_closed_value: 0
    tilt_opened_value: 100

The only problem that I haven’t been able to figure out is that the google integration from HA can only pass open and close…can’t call out a % to adjust the blinds light you would a light bulb. not sure if it’s my config or google integration.

I also recently updated one of my blinds to v5 that mountain just updated (Thanks Mountain!!) so I need to tweak the config when I have some time.

Good luck.


#3

thank you for your reply vez
i tried this already but nothing shows up in my overview panel or devices or entities. Use to have switch in my main overview panel that let me control blinds (with window icon). Right now i have nothing. I guess have to try version V5. Right now running version 107.7. Is there something im missing?


#4

I’m running 107.7, just noticed 108 is now out. The only thing I forgot to mention earlier is that I use Mosquitto broker v4.1. If I upgrade to v5 of Mosquitto broker they no longer work with FW v4. Haven’t tested it with FW v5 and I haven’t had time to figure out why it didn’t work I’ve left it at v4.1


#5

thanks vez but is there anyway to downgrade to mosquitto 4 for dummies like me


#6

Note on difference between V4 and V5 of blind control software.
Version 5 of blind control software follows the same format as Tasmota for its MQTT

As follows:

State topic is stat//STATE
Command topic is cmnd//POWER

The DeviceID is the MQTT Device topic…
eg
BlindControl1 MQTT Device ID
stat/BlindControl1/STATE MQTT Topic
cmnd/BlindControl1/POWER MQTT Topic

the stat and cmnd are formats that tasmota uses and are coded in the software as well as STATE and POWER …note on Upper case

as in the post above for vez727
command_topic: “blinds/utilities/blinds1” v4 format
state_topic: “blinds/utilities/blinds1/state” v4 format

command_topic: “cmnd/blinds/utilities/blinds1/POWER” v5 format
state_topic: “stat/blinds/utilities/blinds1/STATE” v5 format

This should help in upgrading to V5 , also when going to V5 the blind control software will need reconfig via AP mode as there are extra features in V5

I am still working on V5 firmware as we speak as a few features and twiks are needed, these are only minor changes.
one of these is the ability to store MQTT payload or command so in the event of power outage or reboot the blind is in its correct state.
I have noted on power reboot that the servo motor state reports back a random number until s servo read is preformed, which gives incorrect state to HA or Openhab.


#7

thank you Mountain
definitely i will try this in few days, also im trying new esphome. Stay safe friend


#8

Version 5.01 uploaded. Minor bug fixes.
OPEN, CLOSE, ON and OFF commands coded (MQTT commands)

MK-BlindsControl V5.01


#9

just quick update.
i was able to work my blinds with esphome. i think is much easier. Thank you guys for your inputs


#10

Could you please share your esphome yaml . I agree esphome is much easier. Thanks


#12

esphome:
name: t1
platform: ESP8266
board: d1_mini

wifi:
ssid: “”
password: “”

Enable fallback hotspot (captive portal) in case wifi connection fails

ap:
ssid: “t1 Fallback Hotspot”
password: “ijgscP3xnIyC”

captive_portal:

Enable logging

logger:

ota:

Enable Home Assistant API

ESPHome configuration

api:
services:
- service: control_servo
variables:
level: float
then:
- servo.write:
id: my_servo
level: !lambda ‘return level / 100.0;’

servo:

  • id: my_servo
    output: pwm_output

output:

  • platform: esp8266_pwm
    id: pwm_output
    pin: 05
    frequency: 50 hz
    inverted: false

cover:

  • platform: template
    name: "Living Room Left Blind "
    optimistic: true
    open_action:
    • servo.write:
      id: my_servo
      level: -80%
    • delay: 150ms
    • servo.detach: my_servo
      close_action:
    • servo.write:
      id: my_servo
      level: 46.0%
    • delay: 100ms
    • servo.detach: my_servo
      stop_action:
    • servo.detach: my_servo
      has_position: true
      device_class: blind

#13

Thank you very much.


#14

Hi Tadeusz,

I am getting error message in ESPHome for has_postion:

[has_position] is an invalid option for [cover.template]??? Any idea what indentation is required for hos_position?

Thanks.


#15


#16

Thank you very much.


#17

I’m on Mountain’s v6.06 firmware. In Home Assistant, I’m able to send integer commands from the MQTT Integration settings to the blinds with success, but I have two problems:

1) I can’t get the Open/Close/Stop integer mappings to work. Here’s my yaml config:

    cover:
      - platform: mqtt
        name: "LivingRoomBlinds"
        command_topic: "cmnd/Home/cover/LivingRoomBlinds/set/POWER"
        state_topic: "stat/Home/cover/LivingRoomBlinds/set/STATE"
        retain: true
        payload_open: "40"
        payload_close: "100"
        payload_stop: "75"
        state_open: "40"
        state_closed: "100"

2) I can’t get my blinds to show up a device in HA. @tadeusz’s solution worked. The name had to be all lower case. Thanks!

And now it appears that the Integers are working with the options under the entity. Need to create an automation with it now.


#18

Hi everyone, are there any updates to resolving the issues seen ? Does anyone have a “working config” to share ?


#19

what issues you are talking about


#20

Hi tadeusz, I guess I read somewhere in this thread that folk were having issues with the latest in Home Assistant and was just trying to get more info.


#21

cover blind:

  • platform: mqtt
    name: “blinds”
    command_topic: “cmnd/blinds/POWER”
    state_topic: “stat/blinds/STATE”
    qos: 0
    retain: true
    payload_open: “100”
    payload_close: “0”
    payload_stop: “50”
    state_open: “100”
    state_opening: “100”
    state_closed: “0”
    state_closing: “50”
    payload_available: “online”
    payload_not_available: “offline”
    optimistic: false
    value_template: ‘{{ value.x }}’
    tilt_command_topic: ‘cmnd/blinds/tilt’
    tilt_status_topic: ‘stat/blinds/STATE’
    tilt_status_template: ‘{{ value_json[“PWM”][“PWM1”] }}’
    tilt_min: 0
    tilt_max: 100
    tilt_closed_value: 50
    tilt_opened_value: 100
    device_class: blind

This is my file and it works for me. Make sure you not using capitol letters in the name. It will not show up in the devices, it will show up in entities only. You can use entities in automations. Also i have blind set up in home assistant esphome and i believed its much easier.