MQTT Binding 2.4


Hi All

Newbie here.

Newly installed Raspberry Pi with Openhabian Release 9.6 (Stretch) with MQTT Binding 2.4.
I am unable to get my newly build blind control to work (in Openhab) - working 100% when testing it with MQTTfx.

Seems my timing is really bad on this. After spending hours on forums it seems like the new MQTT Binding 2.4 is a totally new way of working with MQTT in Openhab2.

Needless to say - for a newbie like me this has now gone beyond my understanding and I would appreciate some help.

I have tried to follow the steps in this article:

but getting stuck along the way. Hope I am making sense here. Regards

Blinds connected, but socket error

It actually is easier. Just setup the host and port and it should auto discover


I wish :wink:
Up to this point I have created mqtt.cfg files (that didn’t exist) and plenty more. Please keep in mind, the reason I ask for help is because I was not successful. Believe me it was not a lack of trying. So, a bit more guidance will be highly appreciated. Thanks.


I had a hard time too, when trying to get the mqtt binding 2.4 working.
After couple of hours trying without a chance, i uninstalled it and installed the legacy mqtt 1.x and it worked n 5 minutes…


Thanks - I will start from scratch - loaded and tried so many things nothing seems to be the way is should be anymore. - Since I loaded it specifically for my my blinds control (to start with) I don’t have much to loose.


I will try with the new mqtt binding. It also has a built in broker so you don’t need to set up anything else