Mqtt boker setup not working


Let me start by saying I am completly new to this. I can not seem to find a post with the ptoblem I am having.
I have setup my raspberry pi using this tutorial

I have been sucessfull up untill connecting mqtt part 7.

When entering
sudo nano /etc/openhab2/services/mqtt.cfg
My putty sceen has lines to change. The only items are the get help and exit comand area. I can not change broker url. Is this needed with mqqt 2.4 binding? What do I need to do to correct this?


One thing I am going to check is my collumn setting. I remember getting a notifacation that it was below 120. Maybe adjusting this will show the text lines?


As n newbie myself, I ran into the same problem. The issue is the new MQTT binding. It does not create the file in the location specified - that is only the older binding (ver - One suggestion made is to load ver 1.x compatibility and then load an older version of the MQTT binding.

Have a look at my post for the suggestions - Topis: MQTT Binding 2.4


Bassed on this article,

It apears that the broker gets assigned at the time of the device being added through the paper ui. Is this correct?


Setting up your pi server, did you follow Matt’s video here:


I did, but i ended up following this.

Things seem to woking as I was able to build Matt’s demo switch. It is mqtt1.13, and dure if that will cause future pronlems?


Have a look at this short tutorial written on the openhab forum it will help.
Matt, it would be a good idea for another youtube video to walk us through the new MQTT 2.4 install.


I had the same issue. I removed the 2.4 binding. Enabled 1.X bindings and then installed the old version which created the mqtt.cfg file and let me continue with Matts guild.

One more thing i had to do so the commands worked from the basic ui was to copy and paste the items and sitemap back in and re save it. Without doing this i was getting no movement on the servo.


I used the 1.x, followed the guide abd all woked. I followed the basic sonoff guide later and got it to work, for the most part. A guide for the new mqtt would be great.