My blinds are not well


Home Assistan brought two, mqtt broker updates this week. Neither of my blinds have fared well since.

After the first update, neither blind would reconnect to the mqtt broker. Both finally did after restarting my wireless router. Neither would reconnect, however, after the second update. In addition, the web interface has not been accessible since the second update. Note that I’m not necessarily blaming the problems on mqtt here, the blinds are always slightly flaky until they resync after any HA update.

I finally got around to reflashing the easier of the two blinds today. The other is on a double-wide window and is more trouble to take down and put back up. After reflashing and reconfiguring the wireless, host name and mqtt access, the blind came back up but appears to be in a boot loop. The blind comes up, attaches to the mqtt broker, announces its presence and telemetry, then goes silent for a few seconds. Rinse and repeat.

This is with firmware v7.92 which I had been using mostly trouble-free for several months. I vaguely recall some problem with boot loops being mentioned a while back. Perhaps it’s my turn to get bitten by that. Regardless, I’m asking for what to do next. Mountain, if there’s any debug info I can provlide, I’m happy to try. If not, I’ll try flashing an older firmware.


I’m surprised you have to take down the blinds to reflash. I always update wirelessly. It works well. I’m currently at v7.92 and did not see any issues with 6 different blinds. My CPU is the rather large Lolin ESP8266. If I build another I’ll probably use the D1 mini. One thing I noticed with the HA updates is that one of the many updates in the past week caused the CPU temperature to now show in C instead of F. Rather than find where this setting was I just added the math to do the conversion in the YAML but the blinds and all my other MQTT devices were not affected.


I had to take them down to reflash because the web interface was not accessible.


V 7.92 Blind Control Firmware Released for testing
Have a look at this topic.

Similar problems reboot loops etc look at this topic for fix procedures.

Also V7.95 is available as per this topic.


Thanks. I wonder why that topic didn’t show as unread to me.

Anyway, I decided to give standard Tasmota a try this time. My hope is that some of the edge cases I’ve had troubles with, like HA and mqtt broker updates, work more smoothly. So far so good. Tasmota is certainly more tedious to setup and the one shutter mode needed for use with servos would happen to be the only one not supported by HA for auto discovery of Tasmota covers. However, the ability to use TasmoBackup makes up for some of that.


So are you using Tasmota firmware to control blinds now ???


Yes. I followed the minimal configuration outlined at . I used gpio13 for pwm and gpio12/14 for virtual relays and pulse widths of 500us to 2500us. The instructions on the shutter calibration link appear to be dated and didn’t work for me. For now, I simply adjusted the pulse width range to achieve the desired open and close points.