Problems with MK blind control V6


Hi all

Firstly thanks for taking the time to look at my post. I have a fair few issues revolving around the blind module.
A quick background - I have had a MK blind module for ages now but still have not got it installed in the blind as i have not got it to work correctly on the bench. A while ago I had a raspberry PI running things which has Mosquito running - this set up I had control of the blinds.

I have recently moved back to a windows server (running windows 10) to be the host of all things smart. (file server, backup, openHAB, MQTT etc etc)

Blind module is running on a 2A power supply, sat on my bench.

I now still cant get Mosquito to work properly - its set up on the server, i can use MQTT.fx to connect and publish etc but that published message doesn’t seem to get out of the computer. I also can not use MQTT.fx to connect to the server from another computer.

I was having trouble controlling the blind or connecting to the webpage for the device, so decided to update the firmware to V6.5 which seems to work as the webpage comes up with the new version layout etc. I now have the problem were the device keeps coming up with the SSID and not staying connected to the wifi but remembers its settings - it has connected because i see it on the router and it has updated its device name. But then shortly disconnects its self. I also can not access the device webpage via hostname or IP address from any device.

I also jury rigged a button to the PGM RUN pins as per instruction in the Blind Control V6.5 upgrade topic. But this also seems to not work.

So quick summary of my issues which I hope I could get some help with
-mosquito not working outside of localhost (i have allowed port 1883 through server firewall)
-MK blind module dropping connection constantly
-can not access blind module webpage
-Blind module seems to not be receiving MQTT
-blind module button not working

I hope you guys can help, this has been causing me agro for days on end!

Thanks again.


We need to get firmware updated to latest.
V6.5 was complied with WiFiManager library upgrade which was buggy.
I have since re compiled firmware with a down graded Library and the dropouts and SSID problems which I had then have gone too.
download from here now. v6.8-Beta
With the modification adding external switch. Ensure you have the 10K resistor connected between RUN and the middle terminal witch is IO 0, and switch is connected to middle pin and PGM. Ensure all connections are sound as if the IO 0 is not connected properly then the voltage input will float and can cause restarts etc, and entering AP mode etc. Random stuff.
I had loose connection problems using the plug in wires as the seem to be a loose connection. check this.
V6.7 and above have been modified so that the io 0 or external switch must be held to ground or ON for more then 4 seconds to force device into AP mode and reset operations.
Also latest firmware has modifications for external button response etc.

Doing the above should get device to working stable state.

Running on windows platform seems to be a firewall problem and router. possible port fordward 1883 ?.
Is windows pc have fixed IP address…?


Hi Mountain
Thankyou for all tour great advice!
I will try updating again and see how that works, I was using plug in wires and used the jumper to secure the resistor to the RUN pin and a plug in wire to secure the other side of the resistor whilst trying it out. I will just try soldering it direct so stop any loose connections.

Yep host server firewall has rule to allow incoming and outgoing of 1883. Router also has port forward set up for 1883. And pc has static IP

Thanks again for your help and all the work you do for this forum


Yes solder resistor on underside direct. And those plug in wires are a bit dodgy …


So, i have updated using an UNO to the version you linked above, device flashed fine.
moved the jumper to RUN
device showed up on my phone wifi, connected and input the details.
the device then resets with the wifi showing still. But saves the MQTT info etc.
This is with out any resistor or wires for the button
I have tried a couple of times and checked the password is correct etc.
the wifi name is MK-BlindsControl-V6-6228155 If that helps.



When you connect to device in AP mode to setup via phone etc. And you are entering your SSID and password section again you may already see your SSID name already in the field , and may be in a grayed out text.
I found you need to reselect your SSID from the scanned list above then enter SSID password etc, even if other fields are already filled . (The other fields if already filled do strill work)
It appears there is a bug in the WiWiManager library when it comes to EEPROM for the SSID details. This bug only happens when reconfiguring or resetting device too.

So everytime yoI go into re configure, reselect the SSID and enter password.

The SSID and password are the only 2 variables that are stored in EEPROM, the rest are in a JSON file


Thanks for your reply.
It is now not even saving the other info, just reboots and shows is SSID again, it isn’t even showing up on router where as it did before before it then showed its SSID again.
I have tried scanned and no scan both doing the same thing.


Select the SSID from the above list. Then enter SSID Password.

Re enter all other information.
MQTT Server , password if required.
Authorentication TRUE or FALSE
device name and all other details .

If device cannot connect to MQTT Server it will reboot to AP mode. Or if other details are not entered.

Ensure passwords are correct and id’s etc correct.
check for spaces and capitilizations etc.

If GPIO 0 in LOW
Host Name not set
MQTT Server Name not set
MQTT Topic not set

Device will reset and reboot to AP Mode
Can you check these settings again.
Also if you have connected the jumper again ensure good connection in the RUN position.
I have had a loose jumper causing random results before.

If this doesn’t work we need to erase esp and reload.
Using UNO and loader as in tasmotizer. This one does it all you for you. you select your local downloaded bin. NOT tasmota, then tick erase . These seems to work better for me. then other loaders.

This seems to do a full complete erase and install of firmware.

I found pyFlasher not so relaiable


Super basic question…but how do you connect the blinds board to your computer to allow tasmotizer to erase flash the board? I upgraded to v7 & back down to v6.94 (was having problems keeping connected to wifi) & 1 of my 3 boards will NOT render the GUI when I type in the IP, even thoughI see that it connects to my router.


Try re powering board 1 st , I had a similar problem
Re flash requires ttl connection via usb