V 7.92 Blind Control Firmware Released for testing


V .7.92 now available for download.
You will need to download manually and upgrade as the auto upgrade feature links to the old support server which no longer exists. Once you do this upgrade the OTA and version check and auto and manual download will work from the GUI again.

download firmware from:
this upgrade should not break your existing firmware if it is greater then v7.
if less then V7 i.e. v6 and below you will need to reconfigure through the AP wifi setup again.

Fixed several bugs. were minor but needed cleaning up.
full upgrade to JSON v6 latest versions. (big process)
recompile with upgraded libs such as wificlient etc.WiFiManager.

tweeked a few feature in the GUI and reporting stats
tweeked HA discovery

looked into using SSL and HTTPS for this project but decided most IoT devices do not use this function as it has too many overheads. CA certificates etc…Renewals plus needed extra code and esp8266 would need to sync to a time clock for authentication of certificates.

The solar option is 90 percent done…still testing options and suitalbe configurations.
does require mods to PCB for monitoring battery status

Remote button function has been tweeked and working ok. (this does require mod to PCB with a resistor and soldering in are remote switch to open, close and position to 1/2 way and also to force a full reset. if needed
1 click toggles the blind
2 quick clicks positions the blind to 45 degrees
long held click 5 seconds will force the controller into full reset, ie wipe all settings and start afresh setup AP mode also wipes the file system for clean setup with new config files


Mountain Eagle



Updated my test unit from V7.52 and it just keeps rebooting. I’ll try to reset and re-enter the credentials tomorrow, will let you know.


Try a full power reset. I had to do this on one.


I tried reset, but the device would not stay booted long enough to effect a reset. I reprogrammed it with V6.7 that I had from our previous conversations and that worked. I cannot jump to the current V7.92, when I do it fails again. Do you have an archive of 7.52? This is what all my other blinds are running currently. I’d want to try to going from V7.52 to V7.92 rather than V6.7 to V7.92 which fails. Thanks…


I don’t have V7.52 available. (Lost).

Is all your blinds still on V6.7 ?

V6 and V7 had a lot of lib upgrades and also the blind control code was updated with new features and bug fixes.

If your blind works with V6 ok then what I will do is rewrite the upgrade script to wipe the V6 config.json
reformat the file system and reset the device so you need to reconfigure in AP mode again.
And this will create the V7 config.json.

I will post here when I have completed the changes


Only one on V6.7, all others on V7.52. The one on V6.7 was on V7.52 when I tried to update to V7.92 and it failed. Unit just kept rebooting over and over. I had to re-flash the unit with an Arduino just to get V6.7 onto it as it wouldn’t stay online long enough to use the GUI.


Also tried to flash unit with V7.92 with Arduino and had exact same issue, unit just kept rebooting. This was a full reset flash, clear memory and upload V7.92. I’m using an Apple 2.1A output wall charger brick for power.


I had problems uploading etc with Arduino etc, and erasing. So I use Tazmotiser which does the erase and upload with no problems. see this link https://tasmota.github.io/docs/Getting-Started/
You down load the windows version. and use a FTDI FT232 - adapters, you can use a arduino mega board also just need to ground the reset pin and connect the 5V to MK-Smarthose board.

Check that 5V is being supplied to the mk-smarthouse board and NOT 3.2v this is not enough to flash the chip. when programming. I selected 3 v and it went through the process of uploading but became corrupt etc. Rebooting unable to access etc

What I have done on the LAB test
Using Tazmotiser and selecting erase flash installedV6.7 device worked as normal, connect via AP setup etc all ok.

Try something different
Using Tazmotiser and selecting erase flash installed tasmota firmware on the esp8266
This totally erased ESP and installed totally different firmware operating system etc…
Was able to connect via AP and setup this device as a tasmota device.
All functioned ok

I then put the device back into pgm mode and using Tazmotiser erased and loaded the mk-blindcontrol.bin V7.92 latest
Put device back into run mode and connected via AP and setup device as normal
GUI worked etc. no problems

I would try a different uploading method and watch the 5V is connected to this board. Do NOT connect the 5v directly to the esp pin itself

I can’t seem to simulate your fault

re download the firmware again as I have made a slight tweek to ugrade process too…

Let me know how you go



I can successfully flash and control using HA but if I change any parameters and reboot, the device refuses connection and the servo just twitches on occasion. Tried power cycling several times. A reflash fixes it every time.


I had a 2nd set of blinds with V6.0 and it doesn’t have this problem.


Tried loading latest on the 2nd device, exact same results. I had a V6 bin file, loaded it on both devices and things are working ok…getting some random glitches in movement.


Have found a glitch in the upgrade process…if v6 exists will copy as v7 but v6 was never deleted.
So every time system rebooted v6 will be coppied to V7…
new firmware 7.95 now delets v6.json on upgrade to v7.json. so now if you make changes in setup they are ok.
V6 deleted
can down load this version from http://mountaineagle-technologies.com.au/tasmota/mk-blindcontrol.bin

or via the firmware upgrade in the GUI


I don’t have an upgrade issue, I am flashing the firmware using a uno which works fine. I can configure and connect to my wifi and mqtt server and can control in HA (Version 7.95)

I can change from fast to slow which doesn’t require a reboot and everything is fine.

But every time I change a parameter that requires a reboot, it never comes back. Now instead of a little glitch, does a 180 degree rotation every 30 sec or so. I tried changing the device name first, it failed to reboot, reflashed, then tried changing up/down parameter, same result.

I’ve tried both pulling power and using the reboot button in the gui


From the GUI about does it show version 7.95 (I had a similar issue I thought it was loading the new firmware but it retained the old one for some reason, the fix was I still needed 5v connected to the pcb board as well as the TX RX and ground, also I made sure there was a full erase before loading new firmware.) possible fix.

From the GUI go into file manager and do a directory listing. There should not be a v6.json , only a v7.json and a devicestate.dat file .

You are using UNO what software are you using to flash ?

I now have a test setup running…have done several reboots via GUI once it didn’t come back, found it went into AP mode, so I pulled the power and reconnected then it came back OK.

Have you re downloaded this version?



Thanks for the reply. I just tried it again with the same results.

I’m using an uno with PyFlasher 5.0

From here, I didn’t do any screenshots but I went to setup, changed the direction from down to up.
Saved which came back that I needed to reboot.

I clicked the reboot button and it never comes back. I don’t see an esp device in my list of available wifi networks so I don’t think it’s going into AP mode and it still does what seems to be a reset every 30 sec or so.

Also tried cycling power but that didn’t help.


Thanks for screen shots… Helps.
You have done all correct…
Lets try some clean up options…and eliminate some causes.
The devicestate.dat is only created and updated when a command is received from MQTT ie open close etc.
If you re flash and erase, this file should not exist after you enter AP mode and configure as in 1st setup.
this file is used to align servo etc on powerup and reboots.

So Delete this file via GUI Delete option.

The other problem can be retained payloads or messages in the MQTT broker. Retained messages are stored in the database for 3 years.

You must set retained messages = false in ymal file for HA.
Then you need to delete the retained message in the MQTT database, because everytime the device re connects to the MQTT broker it will pick up that ghost message and act on it

you need to delete any retained message relating to cmnd Topics

The only retained messages/topics should relate to LWT last will testament and possible state topics.



replace mk_blindcontrol_test with your device topic

Please click on about in the GUI and there is a section relating to this and a program you can install to allow you to modify the MQTT database ie delete records .


The reset function in The GUI will delete all files ie. v7.json and devicestate.dat and reformats the file system and then forces into AP configure mode.

let me know how you go please.


Thank you!!!

The initial setup from mksmarthouse had retain set to true. I set it to false, deleted everything except for $SYS and it now comes back after a reboot.


Thats good news, I was running out of possible causes…was leading to possible H/W problem. Rlouter etc…

The new version does a lot more live true updates to MQTT regarding status position of blind siginal and telemetry so there is no need for retain = true this causes a lot of problems if you forget about it…



I have been using the MK blinds for a long time now.
At fist I could only get them to work in HA configured like a light.
Later I got them working like a tilt cover. I have been running 6.8 and 6.95 for a while now.

Because I needed to switch to another wifi ap, I thought I would try this version.

After a fresh install with the tasmotizer, I am able to setup wifi and mqtt.
After a restart I can access the web interface.
So I change from fast to slow and I make him visible to HA.
When I hit save and the back button I an not able to access the webinterface anymore.
It is still connected t wifi but does not work.

I have tried v 7.10 with the same result.


you need to upgrade to latest version there was a bug in saving setup information that is now fixed and follow steps above to delete retained messages and set retained = false


I downloaded from the last link in this thread.
That should be v 7.95.
That one also crashes on restart.


Have you removed any retained messages in MQTT database ? see post above.
Use the MQTT Explorer software to do this.

Need more info on crash please
Does the device show up in AP mode on reboot ? i.e. initial setup. after upgrade
Have you removed the power from the device and repowered again.? this can fix the problem on firmware upgrade reloads. ?
(Know bug sometimes can happen cause is NOT my software but the arduino library’s and hardware )

Note on MQTT retained message
The device can appear as in a reboot loop if exist