Blind Control V6.5 upgrade


#21

Thanks for this info. And I had similar problem while testing home assistant I just installed, and testing v.6.7. Blinds were fully opening or closing after a software upgrade or rebooting device via GUI and sometimes power reset via power supply. was random behavour.
I started looking at the code as I just upgraded some libs only.
Have not had this problem. as I use openhab.!!!
I would open the blind via openhab. or home assistant and all works ok.
I launched MQTT.fx and looked at cmnd/# and bingo!!!
the POWER command is set to RETAIN
It was set when I used home assistant to operate the blind.
I then operated the blind via openhab and the command is not retained.

I then stopped MQTT service and deleted mosquitto.db then restart MQTT and retain messages are no longer.
Now when restarts just get a pulse twitch sometimes which is normal on a restart

So yes change the retain to false and you will need to delete your mosquitto.db file and restart MQTT. to remove the retained messages

Thanks for this it has helped to try and resolve this strange problem.

The devices should not restart themselves unless there are problems.
bad connections, dropping out etc
not enough power suppling device. (I use 1.5A USB per blind)
The device uses between 275 mA idle, and 700mA when it transmitts on WiFi and higher when the servo is operating.

Note on Retain (The demon if set to TRUE causes problems)
V2 had retain set to true to keep the device state retained, if the device restarted the true state was not published back to MQTT until a command was received. So your stat information could be incorrect .
From V3 and above I included a telementry service which publishes state info and more to MQTT on restart and every 60 seconds (you can change this in setup).
Tasmota firmware uses 300 seconds as default.


#22

wonderful. So in a nutshell, I should be able to upgrade to v6.5 and have no issues and my yaml file would change. Did you install HomeKit kit also and does it seems to work?

I’m glad for this forum for sure, as it helps us users troubleshoot things. Are you using the MK-SmartHouse Blinds kit from Matt?

Thanks
Mark


#23

You can upgrade to the latest v6.7-Beta now available.
You will need to reconfigure each blind again like a new install. Controller will be in access AP mode. (Going from v2 or below v6 as major changes requires this step)
Once you connect via AP mode, select SSID, password, MQTT ip address etc. Save and reboot.
Then access the device via ip address to continue setup via GUI.
you will then need to change your yml files, command and state topics to suit new format
and change retain to false.

Have installed homekit but not tested, my homekit is on openhab though but i have created a link to this one, will test soon, keen to understand and use home assistant.

Yes I do buy Matt’s Blind Kits and do recommend them to any one else, these kits a great, simple and most of all affordable .

You can download v6.17-Beta from here just click on link should allow download.
Then install as per v2 method.
http://mesmarthouse.com/tasmota/mk-blindcontrol.bin

Also this link in a about/help file you can open.
http://mesmarthouse.com/tasmota/mkblindcontrol.html

Upgrade one blind to see how you go,

Were are here to help.

Cheers


#24

I will try that tonight, or this weekend, so my YAML would be like this?

mqtt:
broker: 10.0.1.111

cover BlindsControl1:

  • platform: mqtt
    name: “MK Blinds”
    command_topic: “cmnd/MK-SmartHouse/utilities/MK-BlindsControl1/POWER"
    state_topic: “stat/MK-SmartHouse/utilities/MK-BlindsControl1/STATE"
    retain: false
    payload_open: “0”
    payload_close: “100”
    payload_stop: “STOP"
    state_open: “0”
    state_closed: “100”

#25

Yes that looks good, and will work, make sure you match the mqtt topic in setup of device
The base topic
MK-SmartHouse/utilities/MK-BlindsControl1


#26

Hi,

I’ve updated the blinds to be V6.15 and it seems to work. I still have this in my config file but it so far has not shuttered.

2021-01-17 14:43:42 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 14:44:56 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 52
2021-01-17 14:45:00 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 14:45:02 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 14:45:24 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56

This is 1/5, I was a bit nervous to do it, but seems HomeKit and Siri are still able to see it. I did change my config.YAML file to the following:

mqtt:
broker: 10.0.1.111

cover BlindsControl2:

  • platform: mqtt
    name: “HK Blinds"
    command_topic: “cmnd/MK-SmartHouse/utilities/MK-BlindsControl2/POWER"
    state_topic: “stat/MK-SmartHouse/utilities/MK-BlindsControl2/STATE"
    retain: false
    payload_open: “0”
    payload_close: “100”
    payload_stop: “STOP"
    state_open: “0”
    state_closed: “100”

So far so good. Thanks for your help, if this works, I will updates my whole other blinds. :slight_smile:


#27

one more question. How do I get the GUI screen would it be the same way as before?

mk-blindscontrol2.local in the URL?

As that doesn’t seem to work.
Maybe the IP addresss?

Yup… that seemed to do it


#28

Thanks for upgrade results. and it went ok for you…
did you restart home asistant after you changed yml file?

I am new to home assistant (I now a new be!!! lol). As I use openhab. But I am liking what I see in Home Assistant too , just a mater of learning It and getting help.
I have both systems running and I am looking at a whole new yml config for the blind system as there are more option now available…and maybe asking help from Home Assistant Users.
I am trying to work out why you are getting this error also. I don’t see it yet in my logs. But I don’t have homekit fully functioning yet.

There are a couple of ymal examples regarding blinds and covers I am looking at on the Home assistant Tasmota intergration that look promising .


#29

Hi Mountain,

Thanks for you help for sure! Yeah I’m learning about it too. So far so good, I am getting this error lots, but the blinds are not “freaking out” as they did before this update

2021-01-17 16:25:25 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 16:26:24 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 16:27:24 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56
2021-01-17 16:28:25 WARNING (MainThread) [homeassistant.components.mqtt.cover] Payload is not supported (e.g. open, closed, opening, closing): 56


#30

Also… is the only way to get to the web config page via the IP address now?


#31

Yes web page access via IP address.
If you run windows machine goto file browser, network and you should see the blind controller listed. left click will open the web page, right click will give you help info etc.,


#32

Hi Mountain,

I’m on a Mac, I was looking to see in their network under finder. I thought that the web interface could come up by the name of the blind, but IP address is still good to use, but it’s just that address could change (unless forced or given by my router).

I’m still getting the error message every minute, but the blinds are not moving and they seem to obey the HomeKit scene I’ve sent to open 30min before sunrise and 30min after sunset.

It’s become an event in our house with my 10 year old son, watching the blinds open or close, and of corse asking Siri to open close, 50% etc.


#33

So I updated all my blinds. So far, looks good, 1 blind seems to run the motor after it sets the position. (without stopping). I had to restart it. Is that the best way to let the blinds reset? I will see tomorrow if they work on the sunrise.

Other blinds seem fine no issues.


#34

Good they went well, rebooted one ok, strange behaviour it does happen


#35

I just reset it and reloaded it. It seems to behave now. Much easier to reset your version 6, than the version 2 with the jumper.

= wonderful improvement!

Thanks so much!


#36

By the way, does the location of the motor (left or right) make a difference or is it just for documentation?


#37

Yes, must be setup to the correct side in config, as it determines the blind behaviour in opening and closing commands and also swing direction to close, eg if motor is on right by default and you issue open aka 0, blind will move in correct direction, but if you put the motor on the other side commands are reversed because motor is now opposite. Most blinds are left side but you do get the odd right and install, also swing to close, most people have swing down to close but some have swing up, this needs to be set before connecting motor to blind shaft.


#38

I have set the defaults as per v2 as these weren’t thought of, new config options,
Swing direction
Side motor installed
These affects the blinds behaviour as to commands it receives,
blinds swing up to close this reduces more light and heat entering room,
default is down to close, does require physical realignment to change direction as well.
Having all these extra options allow the blind to be configured more for the user


#39

So after updating that 3rd blind, all blinds worked great this morning. And also closed at sunset. So nice.

Thanks so much Mountain for all the you have done and helps.


#40

Great it all went well and I am relieved too as this was a big upgrade, I was trying to cover all possible things could go wrong in upgrading and developing code to fix ,
Also check the about menu option this is a live document which I am still adding to.
Have a look at firmware option as there is a check button for updates
Still looking into home assistant integration and also the error re state in HomeKit mm

Thanks for using this v6 platform