Blind Control V6.5 upgrade


I had another question. I bought some of Matt’s circuit boards and some ESP8266 from AliExpress, how do I upgrade the firmware on a chip (not purchase from Matt version 2?). I had bought this, for surplus incase I screwed up something in my setup.


Yes you can install firmware onto a blank esp8266 chip. does require serial connection via usb-ttl device and using aflash program such as pyflasher.
Matt’s web site covers how to do this
and look at this as well
Have used this before to load firmware onto blank esp’s.
if you get stuck let us know…


Hi Mountain,

Thanks for all the time you’ve invested. I recently upgraded the AP’s in the house to a mesh setup…one thing I have noticed with my blinds is that when they move from AP to AP (to load balance) they do a little reset, and sometimes randomly move. It appears that they’re initiating another DHCP request. Is there a way we could add static IP’s to them…would this fall under feature request? :slight_smile: Out of all 60+ devices in my house, they are the only ones that are finicky. Once again, thanks for all your time and effort.


What version of firmware are you running in Blinds?


Hi. I have a mix of v6.06 and v6.6.


There is a new version V6.8-Beta.
This has been compiled with updated wifiManager and other libs from Arduino .
WiFi Manager was a major update.
Someone here also had similar problem with random moves etc. This new upgrade seemed to help.
You should be able to upgrade from 6 above to this new version via OTA method without needing reconfigure in AP mode
You can download this version now from the repo server
See if that will improve the response


Thanks. I will update tonight and see if it still continues.


Hi I’ve been running then latest v6.8-beta and it still does the random twitch. I’ve been trying to troubleshoot but it seems to be related to moving between the AP’s within my mesh. If I have time this weekend, I will pull out an old AP and set it up to see if it still does the same thing. thanks.


Do they have good power supplies. 1 amp plus. ?
check MQTT database for Retained messages. There should not be any retained messages for commands etc. If using homeassist the ymal setting had retained=true set, this should be false as the software now has telementry to report back state etc
I had a similar problem on reboot, device was picking up a retained message from long ago and acting apon this message. ie moving. I deleted mqtt database to remove all retained messages.


I never thought about the retained messages…just cleared all of them and more (found some old stuff)

It’s been over an hour and my wife has not complained. :slight_smile:

Hopefully that was it. I’ll post back in a few days. THANKS!


Quick Update. Removing all retained messages for the blinds in question within the MQTT DB fixed the issue. They no longer twitch or randomly move.

Thanks again Mountain for the suggestion!


Great to see resolved the issue. Thanks for feedback.
Also note on retained messages. The only retained message in MQTT database should be LWT messages


Hi Moutain,

I just setup my last blinds I just got from Matt with V2, I updated it via the firmware update page, and noticed the latest version is V6.8 Beta, but it doesn’t allow the 50% open like my other blinds. It does allow OPEN and CLOSE, so is this the new functionality?

Here’s my YAML file:

cover BlindsControl5:

  • platform: mqtt
    name: “KK Blinds”
    command_topic: “cmnd/MK-SmartHouse/utilities/MK-BlindsControl5/POWER”
    state_topic: “stat/MK-SmartHouse/utilities/MK-BlindsControl5/STATE”
    retain: false
    payload_open: “0”
    payload_close: “100”
    payload_stop: “STOP”
    state_open: “0”
    state_closed: “100”



It should not have changed, I have not touched the code for this function. , Can you show me the ymal code for the other blinds that are working, and what version they are running please, maybe payload stop should be 50 ??? not sure at this stage.


v 6.8 Beta, the other ones are V6.7-Beta.

So you think it should be like this?

cover BlindsControl5:

  • platform: mqtt
    name: “KK Blinds”
    command_topic: “MK-SmartHouse/utilities/MK-BlindsControl5”
    state_topic: “MK-SmartHouse/utilities/MK-BlindsControl5/state”
    retain: true
    payload_open: “0”
    payload_close: “100”
    payload_stop: “56” vs new -> payload_stop: “STOP"
    state_open: “0”
    state_closed: “100”


Can I go back to V6.7-Beta, I think I still have that file. Or do you always go forward?


go forward…
try payload_stop : “56” and test this, you will have to resart homeassist if you edit ymal file.

Are the other blinds are using the latest firmware? and payload_stop : “56” or payload_stop : “STOP” ?


The 56 seemed to work, and the other blinds are V6.7 Beta with this YAMlL

cover BlindsControl4:

  • platform: mqtt
    name: “DK Blinds”
    command_topic: “cmnd/MK-SmartHouse/utilities/MK-BlindsControl4/POWER”
    state_topic: “stat/MK-SmartHouse/utilities/MK-BlindsControl4/STATE”
    retain: false
    payload_open: “0”
    payload_close: “100”
    payload_stop: “STOP”
    state_open: “0”
    state_closed: “100”


Also Thers a new version availabe 6.8 Beta.

If 56 works then use it.
Do you have a button to send a HALF command or a STOP command payload?


With Apple HomeKit setting it around 50, makes it 56